キーワード

現象

gradle sonarqubeすると次のエラーになる。

:sonarqube
FAILURE: Build failed with an exception.

* What went wrong:
org.gradle.internal.jvm.Jvm.getRuntimeJar()Ljava/io/File;

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


BUILD FAILED

原因

Gradleのバージョンが3だとだめらしい(sonarqubeのプラグインが2.0.1の場合は)

対策

sonarqubeの新しいプラグインを使う

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "org.sonarsource.scanner.gradle:sonarqube-gradle-plugin:2.3"
  }
}

apply plugin: "org.sonarqube"

2.0.1を使い続けたい場合

バージョン2のGradleを利用する(sonarqubeのプラグインが2.0.1の場合は)

/path/to/v2gradle/bin/gradle snarqube

備考

Gradleが3になったのは Aug 15, 2016 からみたい。

参考

Last-modified: 2017-03-31 (金) 20:50:39 (905d)